Service disruption at the Frankfurt (DE) data center

Incident Report for Kinsta

Resolved

Our Engineers have successfully restored full service to all affected sites in the Frankfurt (DE) data center. If you are still seeing issues with your website please contact our support team. Thank you for your patience and we do apologize for any disruption to your business.
Posted Dec 15, 2025 - 17:54 UTC

Monitoring

We have implemented a fix and are monitoring the results.
Posted Dec 15, 2025 - 17:27 UTC

Update

Our Engineers are continuing to investigate the issue.
Posted Dec 15, 2025 - 16:47 UTC

Investigating

Our Engineers are investigating reports of a service disruption affecting some sites in the Frankfurt (DE) data center. We are working to restore service to affected sites as quickly as possible.
Posted Dec 15, 2025 - 16:15 UTC
This incident affected: Frankfurt, Germany data centers.