Amsterdam datacenter outage

Incident Report for Kinsta

Resolved

We've confirmed all sites are once again reachable. If you have any other questions, please reach out to our support team via chat, or by emailing us at support@kinsta.com.
Posted Jun 08, 2026 - 16:58 UTC

Monitoring

A fix has been implemented by our datacenter provider and we are monitoring the results.
Posted Jun 08, 2026 - 16:19 UTC

Investigating

Some servers in the Amsterdam datacenter are not reachable. We are currently working with our provider to determine a cause and resolve this as quickly as possible.
Posted Jun 08, 2026 - 15:51 UTC
This incident affected: Amsterdam, Netherlands data center.