Downtime issues in London datacenter

Incident Report for Kinsta

Monitoring

At this time we are seeing that service to all affected sites in the region should be restored. We are continuing to monitor the region to ensure ongoing service stability. If you are still seeing issues with your website please contact our support team. Thank you for your patience and we do apologize for any disruption to your business.
Posted Jan 23, 2026 - 22:28 UTC

Update

We are continuing to see more sites come back online, and will continue to work on resolving any issues with the remaining sites, and monitor for stability.
Posted Jan 23, 2026 - 19:55 UTC

Update

Some sites may be coming back online, at least partially. This issue is still being worked on however, and is not fully resolved.
Posted Jan 23, 2026 - 18:26 UTC

Update

Our cloud provider is still working on a full resolution to this issue.
Posted Jan 23, 2026 - 16:09 UTC

Identified

We have confirmed that this is related to an issue at our cloud provider, and we are working with them to reach a resolution.
Posted Jan 23, 2026 - 14:39 UTC

Update

Our investigation suggests that this might be related to our cloud provider and we are working with them to try and determine the cause so that we can start working on a solution.
Posted Jan 23, 2026 - 13:54 UTC

Investigating

We are getting reports of downtime and performance issues for sites hosted in London datacenter. We are currently investigating the issue and will provide updates as we make progress.
Posted Jan 23, 2026 - 12:58 UTC
This incident affects: London, United Kingdom data centers.