Mykinsta dashboard issues

Incident Report for Kinsta

Resolved

This incident has been resolved.
Posted Jun 01, 2026 - 13:54 UTC

Update

A permanent fix has been successfully deployed, and dashboard access is fully restored. We are now monitoring the platform closely to ensure long-term stability and to confirm that the integration with Apollo GraphQL remains stable.
Posted Jun 01, 2026 - 10:56 UTC

Monitoring

We have deployed a temporary workaround that should restore dashboard access for most users, but the underlying issue is not yet fully resolved and may surface again. We are continuing to work toward a permanent fix.
Posted Jun 01, 2026 - 08:35 UTC

Identified

We have identified the root cause of the dashboard inaccessibility. The issue stems from a disruption with our Apollo GraphQL integration. We are actively working together with the Apollo team to resolve the issue and restore full access as quickly as possible.
Posted Jun 01, 2026 - 07:17 UTC

Investigating

We are currently investigating issues with Mykinsta dashboard. If you need to contact the support team in the meantime, please email support@kinsta.com.
Posted Jun 01, 2026 - 06:20 UTC
This incident affected: MyKinsta.