Our Engineers have successfully restored full service to our control panel, MyKinsta. If you are continuing to experience any issues with MyKinsta please contact our support team by contacting us via live chat, or by sending an email to support@kinsta.com. We do apologize for this disruption to your business.
Posted 12 days ago. Mar 23, 2025 - 16:55 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 12 days ago. Mar 23, 2025 - 14:52 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted 12 days ago. Mar 23, 2025 - 14:10 UTC
Investigating
We received reports of certain pages not loading within the MyKinsta dashboard, such as the WordPress site list and its sub pages. There are also reports of certain MyKinsta actions not being performed. We are currently investigating and will provide updates once they become available. Thanks for your understanding