MyKinsta service disruption
Incident Report for Kinsta
Resolved
This incident has been resolved.
Posted Jan 25, 2023 - 12:28 UTC
Monitoring
Our engineers have implemented a fix and we are monitoring the results.
Posted Jan 25, 2023 - 10:31 UTC
Investigating
Our Engineers are investigating reports of performance issues with our control panel, MyKinsta. We are working on restoring normal service to MyKinsta as quickly as possible.
Posted Jan 25, 2023 - 07:48 UTC
This incident affected: MyKinsta.