Service disruption at the Virginia (US East 4) data center
Incident Report for Kinsta
Resolved
The incident has been completely resolved. All services are now fully available.
Posted Aug 12, 2020 - 08:13 UTC
Monitoring
All Live and Staging sites have been restored. The services are all fully available now. Our engineers are monitoring the infrastructure further.
Posted Aug 12, 2020 - 07:25 UTC
Update
Services to live sites have been restored, our engineers are continuing to work on restoring services to staging sites.
Posted Aug 12, 2020 - 05:14 UTC
Update
Our engineers are continuing to work on restoring services to affected sites.
Posted Aug 12, 2020 - 03:27 UTC
Update
The ongoing issue is due to an apparent hardware failure at Google Cloud. We've been working with Google Cloud Support seeking resolution but at this time an ETA on restoration of the affected virtual machine is unavailable from Google Cloud. Due to the ongoing uncertainty regarding when the hardware failure will be resolved, we've made the decision to restore the affected machine from our most recent backup.

Backup restoration is in process now.

We will continue working with Google to seek the retrieval of all data leading up to the point where the hardware failure occurred and we will provide additional information as soon as possible.
Posted Aug 12, 2020 - 01:17 UTC
Update
Our engineers are continuing to work with Google engineers on restoring services as quickly as possible however the affected machine is still showing a host error status at this time.
Posted Aug 12, 2020 - 00:55 UTC
Update
Our engineers are continuing to work with Google engineers on restoring services as quickly as possible however the affected machine is still showing a host error status at this time.
Posted Aug 11, 2020 - 23:27 UTC
Update
Google are investigating the incident but have not yet identified the root cause. We continue to monitor the affected machine which is still showing a host error status at this time.
Posted Aug 11, 2020 - 22:26 UTC
Update
We are continuing to monitor the affected machine which is still showing a host error status at this time.
Posted Aug 11, 2020 - 21:23 UTC
Identified
A single machine in the US East 4 datacenter is currently affected by a host error due to failed hardware. Google has not posted any regional outages on its status page to reflect this and so we believe the incident is isolated at this time.

We will provide a further update as more information becomes available.
Posted Aug 11, 2020 - 20:42 UTC
Investigating
Our Engineers are investigating a service disruption affecting sites in the Virginia data center. We are working to restore service to affected sites as quickly as possible.
Posted Aug 11, 2020 - 18:56 UTC
This incident affected: Northern Virginia (US) data center.