Mykinsta dashboard issues

Incident Report for Kinsta

Resolved

This incident has been resolved.
Posted Jul 14, 2026 - 09:58 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2026 - 08:43 UTC

Investigating

We are currently investigating a number of reports of failed actions (backups, push action, etc.) in Mykinsta.
Posted Jul 14, 2026 - 08:14 UTC
This incident affected: MyKinsta.