MyKinsta service disruption

Incident Report for Kinsta

Resolved

This incident has been resolved.
Posted Dec 24, 2024 - 09:17 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 24, 2024 - 06:57 UTC

Investigating

Our Engineers are investigating reports of performance issues with our control panel, MyKinsta. We are working on restoring normal service to MyKinsta as quickly as possible.
Posted Dec 24, 2024 - 06:48 UTC
This incident affected: MyKinsta.