Most analytics data is now up to date; however, our system is still backfilling the cache-related data in Analytics. We will continue to provide updates until all analytics data is fully up to date. Thank you for your continued patience.
Posted Feb 23, 2026 - 03:59 UTC
Update
At this time most analytics data should be available and displaying properly from within MyKinsta. However, additional time is needed for all cache related analytics data to become present. We appreciate your patience while our team works on fully resolving this matter. If you do have any questions please do not hesitate to contact our Support team. We apologize for any inconvenience this may have caused.
Posted Feb 22, 2026 - 18:26 UTC
Update
We are still investigating this issue and apologize for any inconvenience it may have caused.
Posted Feb 22, 2026 - 06:57 UTC
Update
We are still investigating this issue and apologize for any inconvenience it may have caused.
Posted Feb 22, 2026 - 02:19 UTC
Identified
Our Engineers are aware of reports of performance issues with the analytics data reported in MyKinsta. We have identified the cause of the issue and a solution has been implemented. It will take some time for all data to become present in the analytics system. We appreciate your patience while full service is restored. If you do have any questions please do not hesitate to reach out to our Support team. We apologize for any inconvenience this has caused.
Posted Feb 21, 2026 - 16:48 UTC
This incident affected: MyKinsta analytics servers.