Application Performance Monitoring (APM) tool not recording data

Incident Report for Kinsta

Resolved

While we have determined the root cause of this issue, it is going to be resolved by further upgrades to our monitoring system. This is expected to be fully resolved next week, but in the meantime should not have a significant impact on monitoring attempts.

If you have any further questions, please contact our support team.
Posted Dec 12, 2025 - 17:19 UTC

Identified

We've identified an issue preventing "Slowest transactions" and "Transaction samples" from displaying properly in our APM tool. We are working on a fix for this.
Posted Dec 12, 2025 - 14:12 UTC

Investigating

We are currently investigating an issue with the data not being recorded in our Application Performance Monitoring tool (APM).
Posted Dec 12, 2025 - 14:02 UTC
This incident affected: MyKinsta.