Cloudflare API requests issue

Incident Report for Kinsta

Resolved

This issue has been resolved.
Posted Nov 04, 2025 - 16:54 UTC

Monitoring

The issue with the Cloudflare API appears to be resolved; we're now monitoring to ensure that this is fully fixed.
Posted Nov 04, 2025 - 16:05 UTC

Investigating

We are currently investigating an issue with the Cloudflare API that is causing some requests for domain verification and addition, as well as site creations and pushes, to fail.
Posted Nov 04, 2025 - 15:47 UTC
This incident affected: MyKinsta.