MyKinsta service disruption
Incident Report for Kinsta
Postmortem

The MyKinsta outage today was caused by an error in a database table that contains site domain information. A software bug caused the error, and no data was lost or compromised in any way.

Within about 15 minutes of the failure, we had identified and fixed the bug that caused the error. The outage lasted beyond those 15 minutes because we had to exercise caution replacing the backup data (because there was also live, unaffected data remaining in the table).

We understand that MyKinsta outages can impact your ability to conduct business, which is why we take the integrity and reliability of the system very seriously. It's critically important, and we all work to ensure that problems like this do not occur. If they do, we're always prepared to take quick action. Today's emergency response involved dozens of people from Kinsta's development, engineering, and management teams.

To reiterate, we've identified and fixed the bug that caused the problem, and we're confident that we will not see the same problem again.

We know you rely on us, and we take that responsibility seriously. We sincerely regret the outage today and any problems it may have caused you.

Posted Mar 25, 2021 - 20:54 UTC

Resolved
Affected sites are now correctly displaying domains in the site domain page and this issue is resolved.

If you see any further issues within MyKinsta, please let us know by reaching out to our support team.
Posted Mar 25, 2021 - 20:50 UTC
Update
Our engineers are continuing to work on the small number of affected sites which are missing domains from the site domain page.

MyKinsta functionality remains normal at this time for all but this small number of sites. If you encounter any issues, please reach out to our support team.
Posted Mar 25, 2021 - 20:28 UTC
Update
Our engineers have brought the MyKinsta dashboard back online and it should now be available for use.

There are a small number of sites that may be missing domains from their site's 'domain' list.
Our engineering team is working to resolve the issues affecting these sites and we will provide another status page update once that is resolved.
Posted Mar 25, 2021 - 18:48 UTC
Update
Our team is continuing to implement a fix for the underlying problem.

We will provide another update at 19:00 UTC.
Posted Mar 25, 2021 - 18:32 UTC
Update
Our engineers are currently implementing a fix and are working to bring the MyKinsta dashboard back online.

We will provide an update at 18:30 UTC.
Posted Mar 25, 2021 - 18:03 UTC
Identified
Our engineers have identified a problem within our database and are temporarily going to place MyKinsta into maintenance mode. We will provide an update here once the service is restored.

Access to support will not be available within the dashboard as a result of placing MyKinsta into maintenance mode.

If you have an urgent issue, please reach out to our support team via email by mailing support@kinsta.com.
Posted Mar 25, 2021 - 17:28 UTC
Investigating
Our Engineers are investigating reports of issues with site domains within our control panel, MyKinsta. We are working on restoring normal service to MyKinsta as quickly as possible.
Posted Mar 25, 2021 - 17:23 UTC
This incident affected: MyKinsta.