Transactional email deliverability issue (latency)
Incident Report for Kinsta
Resolved
MailChannels has successfully resolved the issue, and as such, we're marking our status page as resolved.
Posted Apr 22, 2024 - 18:43 UTC
Update
We are continuing to monitor the situation and await updates from MailChannels.
Posted Apr 22, 2024 - 17:14 UTC
Update
MailChannels have confirmed that legitimate emails which were delayed have now been delivered. However, they are still seeing increased latency. We'll continue to provide updates as they become available.
Posted Apr 22, 2024 - 15:24 UTC
Identified
We are continuing to monitor the situation and await updates from MailChannels.
Posted Apr 22, 2024 - 14:31 UTC
Update
Mailchannels disclosed that the delivery is slow for a small percentage of traffic. They are trying to clear out all the messages in their queues as fast as possible.
Posted Apr 22, 2024 - 13:11 UTC
Update
Mailchannels is continuing to investigate the issue. https://status.mailchannels.net/
Posted Apr 22, 2024 - 12:29 UTC
Investigating
The provider of our transactional email service, Mailchannels, is currently investigating the issue of latency in email deliverability with our transactional email system.

https://status.mailchannels.net/
Posted Apr 22, 2024 - 10:10 UTC
This incident affected: Outbound Email System.