Issues in Amsterdam data center

Incident Report for Kinsta

Resolved

This incident has been resolved.
Posted Jun 11, 2026 - 11:44 UTC

Monitoring

The affected hosting machines are booting up, the sites are now online and we're monitoring.
Posted Jun 11, 2026 - 08:55 UTC

Investigating

We are currently investigating the issues in Amsterdam data center.
Posted Jun 11, 2026 - 08:08 UTC
This incident affected: Amsterdam, Netherlands data center.