MyKinsta service disruption
Incident Report for Kinsta
Resolved
Our Engineers have successfully restored full service to our control panel, MyKinsta. If you are unable to log into MyKinsta or are experiencing issues please contact our support team by sending an email to support@kinsta.com. We do apologize for this disruption to your business.
Posted May 08, 2023 - 19:44 UTC
Identified
Our Engineers have identified the source of performance issues with our control panel, MyKinsta. We are currently working on a fix to restore normal service to MyKinsta as quickly as possible.
Posted May 08, 2023 - 19:15 UTC
Investigating
Our Engineers are investigating reports of performance issues with our control panel, MyKinsta. We are working on restoring normal service to MyKinsta as quickly as possible.
Posted May 08, 2023 - 18:52 UTC
This incident affected: MyKinsta.