Domain verification delay

Incident Report for Kinsta

Resolved

The fix does appear to have resolved the issue and domains are verifying properly at this time. If you do continue to experience any issues however please do not hesitate to contact our Support team.
Posted Oct 06, 2025 - 01:44 UTC

Monitoring

Cloudflare has deployed a fix and we are monitoring the situation. If you do continue to experience any domain verification delays please do not hesitate to reach out to our Support team.
Posted Oct 05, 2025 - 22:11 UTC

Identified

Our Engineers are aware of an issue causing a delay in the domain verification process on our platform. This appears to be related to an SSL provisioning delay on Cloudflare's end. Cloudflare is working on implementing a fix at the moment. You may find a link to Cloudflare's status page regarding this issue here: https://www.cloudflarestatus.com/incidents/41jfgl7cmcsg

We will provide updates as they become available.

If you do have any questions please do not hesitate to reach out to our Support team.

We apologize for the inconvenience this causes and appreciate your patience and understanding while a fix is implemented.
Posted Oct 05, 2025 - 17:26 UTC
This incident affected: Cloudflare Integration.