Email deliverability issue with Kinsta's transactional email service (MailChannels)
Incident Report for Kinsta
Resolved
MailChannels has indicated the issue is resolved at this time. If you do experience any email deliverability issues however please do not hesitate to reach out to our Support team via MyKinsta or at support@kinsta.com.
Posted Jan 30, 2025 - 21:09 UTC
Investigating
MailChannels is currently experiencing higher than usual connection latency, which may affect email delivery services, as noted on their status page - https://status.mailchannels.net/incidents/5vf3bxd6dt8s. We are closely monitoring this incident.
Posted Jan 30, 2025 - 17:44 UTC
This incident affected: Outbound Email System.