Domain Verification issues in MyKinsta
Incident Report for Kinsta
Resolved
The issue with SSL provision has been resolved! Cloudflare also has updated their status as "Resolved".
If you're still experiencing any issues with it, please reach out to our support team for further assistance!
Posted Jul 16, 2024 - 07:24 UTC
Update
Our third-party service provider, Cloudflare, has updated their status https://www.cloudflarestatus.com/incidents/5vr2mkfstysj ,
and mentioned that a fix has been implemented and they are monitoring the results.
We will be monitoring this too from our end now.
Posted Jul 16, 2024 - 07:05 UTC
Update
The issue with SSL provision is still ongoing. Our third-party service provider, Cloudflare, is actively working on implementing a fix to resolve the problem.
Posted Jul 16, 2024 - 05:56 UTC
Identified
The issue has been identified, and a fix is being implemented by our third-party service provider, Cloudflare, to address an ongoing issue with SSL provision on their end.

Related issues can be found here: https://www.cloudflarestatus.com/incidents/5vr2mkfstysj
Posted Jul 16, 2024 - 04:00 UTC
Investigating
We are currently investigating an issue where customers' newly added domains are having problems with domain verification and SSL renewal for expired existing domains.
Posted Jul 16, 2024 - 03:47 UTC
This incident affected: MyKinsta.