Issue with MyKinsta Analytics data

Incident Report for Kinsta

Resolved

This incident has been resolved.
Posted Apr 05, 2026 - 00:23 UTC

Update

We are continuing to investigate this issue.
Posted Apr 04, 2026 - 07:07 UTC

Identified

We have identified the cause of the issue and a solution has been implemented. It will take some time for all data to become present in the analytics system.
Posted Apr 04, 2026 - 05:19 UTC

Investigating

We are investigating issues with Analytics data which might not be logged at the moment: Visits, Bandwidth, CDN Bandwidth. We'll provide updates as we make progress.
Posted Apr 04, 2026 - 03:55 UTC
This incident affected: MyKinsta analytics servers.