MyKinsta Support System Unavailable
Incident Report for Kinsta
Resolved
This incident has been resolved.
Posted Nov 24, 2020 - 15:19 UTC
Monitoring
Our support system is now available though we will continue to monitor to ensure services remains stable.
Posted Nov 24, 2020 - 14:11 UTC
Investigating
Our support system is not currently available. We are working to resolve the issue as quickly as possible.
Posted Nov 24, 2020 - 14:02 UTC
This incident affected: Kinsta support system.