Downloadable/External backups service disruption.

Incident Report for Kinsta

Resolved

This incident has been resolved.
Posted May 27, 2026 - 06:14 UTC

Investigating

We are currently investigating timeout issues related to downloadable and external backups. This feature is temporarily disabled while we continue our investigation. We apologize for the inconvenience.
Posted May 27, 2026 - 05:47 UTC
This incident affected: Kinsta.com.