Kinsta service disruption
Incident Report for Kinsta
Resolved
This issue has now been resolved and Kinsta signups should now function properly. Please reach out to our support team if you continue to have difficulties!
Posted Oct 12, 2021 - 02:17 UTC
Investigating
Our Engineers are investigating reports that some users are unable to sign-up for a new accounts within Kinsta.com. We are working on restoring normal service to Kinsta sign-up as quickly as possible.
Posted Oct 12, 2021 - 01:40 UTC
This incident affected: MyKinsta and Kinsta.com.