SSL certificate issuance delays

Incident Report for Kinsta

Resolved

This incident has been resolved at Cloudflare.
Posted Apr 25, 2025 - 21:59 UTC

Update

Cloudflare is continuing to work on the issue and is awaiting further development from Google Trust Services.
Posted Apr 25, 2025 - 06:56 UTC

Update

Cloudflare is continuing to work on a resolution to this with their certificate authority.
Posted Apr 24, 2025 - 22:02 UTC

Identified

Cloudflare is reporting an issue that is causing SSL certificate issuing delays; this may affect some SSL certificate issuances and renewals inside MyKinsta: https://www.cloudflarestatus.com/incidents/9gqprm9s0vn8
Posted Apr 24, 2025 - 17:05 UTC
This incident affected: Cloudflare Integration.