MyKinsta service disruption
Incident Report for Kinsta
Resolved
This incident has been resolved.
Posted Nov 17, 2023 - 16:39 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 17, 2023 - 16:01 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 17, 2023 - 15:27 UTC
Investigating
Our Engineers are investigating reports of login issues with our control panel, MyKinsta. If you are unable to log in and need to get in contact with the Support team, you can do so by sending an email to support@kinsta.com.

We are working on restoring normal service to MyKinsta as quickly as possible.
Posted Nov 17, 2023 - 14:56 UTC
This incident affected: MyKinsta.